Karlen Communications
Customizing a Table of Contents

Karen McCall, M.Ed.
# Table of Contents

Introduction .............................................................................................................................................. 3

Table of Contents Dialog .......................................................................................................................... 3

Options for a Table of Contents ............................................................................................................... 4

Multiple Tables of Content in a Document ............................................................................................... 7

Modifying the Look of a Table of Contents ............................................................................................... 15

Updating a Table of Contents .................................................................................................................. 19

Other Types of Tables ................................................................................................................................ 20

Updating All Fields ..................................................................................................................................... 20

Troubleshooting Update Fields ................................................................................................................. 25

Contact Information .................................................................................................................................... 26

Table of Figures ........................................................................................................................................... 27
Introduction

This is an advanced topic for working with Tables of Content, Tables of Figures or Tables of Tables in Microsoft Word. This topic starts with the premise that you have created Tables of Content for documents and are familiar with the general keyboard commands for creating a TOC or Table of Contents.

Table of Contents Dialog

This is one of two review topics in this tutorial.

To create a Table of Contents, place your cursor where you want the TOC and press Alt + S, T, C for References Ribbon, Table of Contents, and Custom Table of Contents.

The Table of Contents dialog opens.

Figure 1 Table of Contents dialog.
Options for a Table of Contents

You can choose which Styles appear in a Table of Contents. For example if you have a Heading 1, Heading 1A and Heading 1B, you may only want Heading 1 in the Table of Contents. I’ve come across this type of poor design before.

It is poor design if you are not going to use the other Headings as part of building a Table of Contents for chapters in a book. For example, if you are working on a legacy document and can’t remember or identify visually what Heading level something should be so you create multiple versions of the Heading...that is poor design.

![Figure 2 Table of Contents dialog showing Options button.](image)

The Options button can be activated using the keyboard by pressing Alt + letter O.

You choose your options before you activate the OK button and add the Table of Contents to your document.
You can also change the look of the Table of Contents by changing the level at which items will appear. For example, you can change Heading 1 to number 2 which will indent the text for Heading 1 to the level 2 position in the TOC. You would then move each Heading shown in a Table of Contents down one level so that they would be nested; or, if you want everything in the TOC to be at the same position, you would edit every number to be a number 1. Of course this prevents someone who is looking at the TOC from knowing which topics are nested under other topics...but it is possible to do using the Options dialog for a TOC.

Use the sample document for this tutorial to try various scenarios for identifying the level/position of an item in the TOC.

**Note:** Although you can put many types of Styles into a TOC, generally you only want the Heading Styles in a TOC because they show the hierarchy of content in the document and provide a navigational tool for finding content quickly.

As a reminder, don’t use a Heading Style to call out text. A paragraph is not a navigational point in a document. As a further reminder, don’t use Headings in a table. Table cells are not navigational points in a document. The following image demonstrates how the use of a Heading Style for a paragraph can affect your ability to create a Table of Contents. The image shows a paragraph in a document formatted as a Heading.
Introduction

On the Insert tab, the galleries include items that are designed to coordinate with the overall look of your document. You can use these galleries to insert tables, headers, footers, lists, cover pages, and other document building blocks. When you create pictures, charts, or diagrams, they also coordinate with your current document look. You can easily change the formatting of selected text in the document text by choosing a look for the selected text from the Quick Styles gallery on the Home tab. You can also format text directly by using the other controls on the Home tab.

**Most controls offer a choice of using the look from the current theme or using a format that you specify directly.** To change the overall look of your document, choose new Theme elements on the Page Layout tab. To change the looks available in the Quick Style gallery, use the Change Current Quick Style Set command.

Both the Themes gallery and the Quick Styles gallery provide reset commands so that you can always restore the look of your document to the original contained in your current template. On the Insert tab, the galleries include items that are designed to coordinate with the overall look of your document.

Chapter One

You can use these galleries to insert tables, headers, footers, lists, cover pages, and other document building blocks. When you create pictures, charts, or diagrams, they also coordinate with your current document look. You can easily change the formatting of selected text in the document text by choosing a look for the selected text from the Quick Styles gallery on the Home tab. You can also format text directly by using the other controls on the Home tab. Most controls offer a choice of using the look from the current theme or using a format that you specify directly.

To change the overall look of your document, choose new Theme elements on the Page Layout tab. To change the looks available in the Quick Style gallery, use the Change Current Quick Style Set command.

Both the Themes gallery and the Quick Styles gallery provide reset commands so that you can always restore the look of your document to the original contained in your current template. On the Insert tab, the galleries include items that are designed to coordinate with the overall look of your document. You can use these galleries to insert tables, headers, footers, lists, cover pages, and other document building blocks.

---

**Figure 4 Headings used for callout**

The following image shows the same document with a generated Table of Contents. The Paragraph that is formatted as a Heading shows up in its entirety in the table of Contents. Even visually it is difficult to decode the navigational value of this amount of text in a Table of Contents. For call out text like this, use a Paragraph Style! A Paragraph Style is flexible and customizable to your document branding.

I modify the Quote Style to mimic a call out Text box which lets me use an existing Style but format it so the text is more accessible as attention is drawn to it...and it doesn't appear in a TOC. The “note” text in this document is a demonstration of this technique.
Multiple Tables of Content in a Document

I mentioned that simply using multiple versions of a Heading is poor design EXCEPT when you are going to use those multiple Headings to create a Table of Contents for each chapter in a book or document.

It is easier to leverage the use of Styles in this case instead of using Bookmarks. At least I find it easier and suggest you try it before deciding which method to use.

There is a sample document attached to this PDF tutorial with multiple Tables of Content for each chapter as well as a global Table of Contents for the entire book. Admittedly the document is small for demonstration purposes only.

This is where the second review topic is found.

If, for example, I have a book with 5 chapters and want a Table of Contents for each chapter, I might keep the Heading 1, Heading 2 and Heading 3 as they are in the Styles Pane. I might then duplicate the same Heading Styles with different names, for example, Heading 1 C2, Heading 1 C3 and so forth.

I use the New Style button in the Styles Pane to create the duplicate Styles.
Figure 6 Button for New Style Pane in the Quick Styles Gallery (Top) and the Apply Styles Pane (bottom).

Figure 7 Duplicate Heading Style set up for multiple TOC.
Go into the Options link in the Styles Pane and choose to show the Styles Alphabetically instead of “as recommended.” If you’re using the keyboard, the Options link is the last item in the Styles Pane, so using Shift + Tab will get you there faster than using Tab.

![Figure 8 Styles Pane Options to show Styles in alphabetical order.](image)

The duplicate Heading Styles will appear logically in alphabetical order. This makes them easier to work with and locate when you want to use them.
When you create the Table of Contents at the beginning of the book, all of the Headings are going to be included because we created the new Headings based on existing ones.

When we create the Table of Contents for each chapter, we will tell Word what Styles, in this case Headings, that we want to use for a specific Table of Contents.

After you create your Table of Contents at the beginning of the book, move to Chapter One and place your cursor where you want the Table of Contents for chapter One to appear.

Press Alt + S, T, C for the References Ribbon, Table of Contents, Custom Table of Contents.
The next step is to press Alt + letter O while in the Table of Contents dialog for the Options button and tell Word what Headings we want in the Table of Contents for Chapter One.

For Chapter One, we only want Headings 2 and 3 to appear. We don’t need to have the chapter title (Chapter One) in the Table of Contents for the chapter.

Locate Heading 1 in the list of Styles in the Table of Contents dialog and delete the number 1.

Tab to the other Heading 1 items in the list and remove the number 1 from them as well.

Tab to Heading 2 and leave the number 2.

Tab to Heading 2 C2 and Heading 2 C3 and remove the numbers from those items.

This tells Word that for this Table of Contents we only want Heading 2 and Heading 3.
Figure 11 Table of Contents dialog showing the Headings to be used for Chapter One.

Tab to the OK button and press Enter. You are returned to the Table of Contents dialog.
Tab to the OK button and create the Table of Contents.

You will be asked if you want to replace the existing Table of Contents. Word has taken you to the Table of Contents at the beginning of the document and is asking if you want to replace this Table of Contents.

Say NO!

Figure 12 Prompt to replace the initial Table of Contents.

Word goes back to your current cursor point and generates the Table of Contents for Chapter One.

Move your cursor to where you want the Table of Contents for Chapter Two and repeat the process. This time eliminate all Headings in the Table of Contents Options dialog except Heading 2 C2 and Heading 3 C2.
Figure 13 Table of Contents Options dialog showing Headings for Chapter Two.

Tab to the OK button and press Enter.

When you are returned to the Table of Contents dialog, Tab to the OK button and press Enter.

You are asked again if you want to replace the initial Table of Contents at the beginning of the book.

Say NO!

Repeat the process for Chapter Three.

This time you will eliminate all Headings except Heading 2 C3 and Heading 3 C3.
Figure 14 Table of Contents Options dialog showing Headings for Chapter Three Table of Contents.

Each chapter will now have its own Table of Contents.

Chapter Three

Adding Alt Text to Images .................................................................................................................. 6
Adding Captions to Images .................................................................................................................. 6
Summary ................................................................................................................................................ 7

Figure 15 Table of Contents for Chapter Two.

If you add content to each chapter and use the corresponding Headings for each chapter, you can simply update the table of Contents by pressing the AppKey while focus is in the Table of Contents for the chapter and choosing Update Field (letter U).

As with updating any Table of Contents, you may be asked if you want to update only the page numbers or update the entire Table of Contents.
Modifying the Look of a Table of Contents

There are some accessibility items you should remember when working with a Table of contents. As with any text, avoid using all capital letters, italicized text, bolding everything in a Table of Contents, keep the dot leaders (the dots that go across a line), and don’t over format.

The following image is the customized Table of Contents I use for the tutorial documents I create. I kept everything the same except the Heading 1 items. I made the Heading 1 items bold and the font size 14 instead of the default 12 point. This makes the high level topics in the document stand out and provides an easier visual navigation system.

```
<table>
<thead>
<tr>
<th>Introduction</th>
<th></th>
<th>2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Background</td>
<td></td>
<td>2</td>
</tr>
<tr>
<td>History</td>
<td></td>
<td>2</td>
</tr>
<tr>
<td>Chapter One</td>
<td></td>
<td>2</td>
</tr>
<tr>
<td>Chapter Two</td>
<td></td>
<td>3</td>
</tr>
</tbody>
</table>
```

Figure 16 Sample of a modified Table of Contents.

How did I do that?

When you are creating your Table of contents, activate the Modify futon from the Table of Contents dialog. You do this before you activate the OK button to add the Table of Contents to your document. The keyboard command is Alt + M when you are in the Table of Contents dialog.
When the Modify button is activated, the Styles dialog opens and only the Styles for the Table of Contents are shown. The dialog is organized with the list of TOC Styles in the centre left with buttons to create a new TOC Style or Delete and existing one. We aren’t going to cover either in this tutorial. Most of what you want to do with a Table of Contents is to modify what you have.

The various levels of the Table of Contents are labelled like this:

- TOC1 = Heading 1.
- TOC2 = Heading 2.
- TOC3 = Heading 3.

This is dependent on your use of Headings in your documents. The TOC# relates directly to the hierarchical level of the topic changes or Headings.

The Modify button is below the New and Delete buttons on the right side of the dialog.
Just under the list of TOC Styles is an area which identifies the Font Style and Font Size. Just below that is a more detailed description including indentation and other information about the TOC#. This is accessible if you are using a screen reader.

We are going to modify TOC1 to make it stand out a bit more.

Tab to the list of TOC Styles if you’ve been exploring the dialog. Make sure that Toc1 is selected and press Alt + M to move to and activate the Modify button.

![Figure 18 Style dialog for Table of Contents Style with Modify button highlighted.](image)

The Modify Style dialog opens and the Style name of TOC1 is in focus. Do not change this!

You can now move to the other elements of the Modify Style dialog and make any changes to TOC1 that you want.

Remember that this is a Table of contents not a document!

You want TOC1 to stand out but not overwhelm the entire Table of contents or your document. You also need to make sure that any shading provides good colour contrast and does not make the Table of Contents unreadable.

By Changing this Style, anyone with their own Style Set can swap out your look and feel for the Table of Contents for their own. Once again we are using Styles to provide customization and optimal accessibility.
As with other Style modifications, once you finish making the changes you want, you can choose to either apply the changes to this document only or for new documents based on this template.

The keyboard command to move to those two radio buttons is Alt + D. This moves you to “Only in this document.” Use the Right Arrow to move to “New documents based on this template.”

Tab to and activate the OK button by pressing Enter.

You are returned to the Style dialog with the list of TOC Styles.

Tab to and activate the OK button and you are returned to the Table of Contents dialog. You can now Tab to the OK button and insert the Table of Contents into your document.
When you update the TOC (place your cursor in the TOC and press the AppKey, U to Update field) you won’t have to redo any changes to the TOC Styles. If you had hard coded (selected the text and flung formatting at it), you would have to keep redoing that formatting each time you update your Toc. Another good reason to use the Modify Styles!

Figure 20 Another example of a customized TOC with Heading 1 items bold and shaded light blue.

**Updating a Table of Contents**

As you add and edit content to the template or document you can use the Update Field tool.

Place your cursor anywhere in the Table of Contents and press the AppKey or right mouse button to open the context menu. Press the letter U for Update Field and your fields will either update or you will get a dialog asking if you want to update just the page numbers or all of the Table of Contents.
I usually choose to update everything because that covers any changes to Heading text I may have made as well as any changes in page numbers for content.

**Other Types of Tables**
You can add other types of tables to your documents. The most common are Tables of Figures and Tables of Tables. Using this tool in Word lets people easily find images or data they might want to refer to, double check or cite.

The Table of Figures option is found on the References Ribbon in the Caption Group. Captions must be in place on figures and tables in order to generate a Table of Figures or a Table of Tables. Word uses the Caption field to search your document and find any images or tables.

While we talk about Captions for tables helping people with visual, learning or cognitive disabilities, they also help document authors create more accessible documents in terms of being able to find specific images or data quickly.

In a book like this one, for example, looking for an image of the Modify Style dialog or the location of the Table of Figures option on the Reference Ribbon is helpful to everyone. If this document had data tables, being able to quickly look for the Caption that has the summary information about the table so you can quickly move to the data is also helpful.

Whether you use a Table of Figures, Table of Tables or Table of Equations will depend on the audience for your document and how important it is to let people find things quickly.

Using a screen reader like JAWS, we can get a list of graphics in a Word document (Ctrl + Shift + letter O). In effect we can list figures and find the one we want.
Figure 23 List of figures from the JAWS screen reader.

We can do the same thing with tables (JawsKey + Ctrl + T). The following example is from a tutorial document on using Word to keep track of appointments and contacts. It was written before the accessibility of Outlook was improved to the point that we can use those tools instead. I mention this because some of the tables have the same information shown to a person using JAWS, however the formatting of each table was slightly different.
Figure 24 List of tables in a Word document from the JAWS screen reader.

Although JAWS doesn’t use Captions to search for and provide information on images or tables, the idea is the same...it is a tool to quickly locate the information you need when you need it.

But let’s get back to our Table of Figures!

Press Alt + S, G to generate a Table of Figures.
The Table of Figures dialog looks the same as the Table of Contents dialog. There is one difference: for a Table of Figures, everything is at the same level. There are no indentations.

As with the Table of Contents, you can modify the Table of Figures Style. The process is the same. When in the Table of Figures dialog, press Alt + m to open the Modify Style dialog and make any changes you want to the Table of Figures.

The same “rules” apply as do for a Table of Contents.

You want to make sure you are not using all capital letters, all italics, all bold and a reasonably sized font.

For the Table of Figures at the end of this tutorial, I adjusted the spacing after each item to 10 point to give a bit more space between the Table of Figures items.

Also notice that for some items in the Table of Figures, the text spans two lines. When creating Captions, if you don’t want this to happen, make the Caption text short.
Don’t try to accommodate for long Captions by making the font size in the Table of Figures so small that no one can read it just to make sure that text fits on one line.

![Figure 26 Style dialog to modify a Table of Figures.](image)

Once you’ve modified the Table of Figures Style, Tab to and activate the Close button, then Tab to and activate the OK button and you are returned to the Table of Figures dialog.

You can then Tab to and activate the OK button to generate the Table of Figures.

If you want to add a table of Tables or Table of Equations to your document, the process is easy. If you modify the Table of Figures Style, all Tables will look the same. There is no option to have each one look different. This is a good thing!

To add a Table of Tables or Table of Equations to your document, press Alt + L when the Table of Figures dialog opens. This moves you to and opens the “Include label” setting. The choices are Figure, Table, r Equation or None.

If you are adding both a Table of Figures and a Table of Tables to your document, keeping the labels will be helpful for those reading through the list. keep in mind what they are looking for: tables or figures.

You can update a Table of Figures, Table of Tables or Table of Equations the same yay you update a Table of Contents. Use the Update Field option in the context menu for the table.
Figure 27 Table of Figures dialog showing choice for Table of Tables.

**Updating All Fields**
There is a keyboard command to update all fields in your document including Tables of Content, Tables of Figures or Tables of Tables...or any other field in your document.

The keyboard command is F9.

**Note:** This does not work with the JAWS screen reader. There is no keyboard command conflict so pressing the JAWS Pass Through key (JawsKey + 3) doesn’t work. The keyboard command F9 simply doesn’t work. Fields will have to be updated manually.

**Troubleshooting Update Fields**
Sometimes when you copy an image and it’s Caption from one document to another, the Caption field does not automatically update.
To update the field, simply select the field/number. If you are using a screen reader like JAWS, you will hear where the field is.

Press the AppKey and choose Update field. The numbering of the Captions/figures will fall into line again.

**Contact Information**

You can [contact Karen McCall](#) with any questions about this how to booklet or any suggestions for others. Visit the [Karlen Communications web site](#) for more how to booklets!
Table of Figures

Figure 1 Table of Contents dialog ............................................................................................................ 3
Figure 2 Table of Contents dialog showing Options button ................................................................. 4
Figure 3 Table of Contents Options dialog .............................................................................................. 5
Figure 4 Headings used for callout ........................................................................................................... 6
Figure 5 Paragraph formatted as Heading appearing in Table of Contents ......................................... 7
Figure 6 Sample of a modified Table of Contents .................................................................................. 15
Figure 7 Table of Contents dialog showing Modify button .................................................................. 16
Figure 8 Style dialog for Table of Contents Style with Modify button highlighted ............................. 17
Figure 9 Modify Style dialog for TOC1 .................................................................................................. 18
Figure 10 Another example of a customized TOC with Heading 1 items bold and shaded light blue ........................................................................................................................................... 19
Figure 11 Update Field dialog .............................................................................................................. 20
Figure 12 Caption Group from the References Ribbon .......................................................................... 20
Figure 13 Table of Figures dialog .......................................................................................................... 23
Figure 14 Style dialog to modify a Table of Figures .............................................................................. 24